EC Aficionado (was: The Studio Jr.)

Discussion in 'Eddie Current' started by AppleheadMay, Nov 10, 2015.

  1. kirayamato

    kirayamato Friend

    Friend
    Joined:
    Oct 18, 2015
    Likes Received:
    36
    Trophy Points:
    28
    5AR4 rectifier tube is the stock one thats comes with the amp
    so is the one thats infront of the 2a3's i ordered a WE 396A hopefully that fixed a problem any good recommendation for a rectifier tube?
     
  2. kirayamato

    kirayamato Friend

    Friend
    Joined:
    Oct 18, 2015
    Likes Received:
    36
    Trophy Points:
    28
    @Ray what tube are you using infront of the 2a3's if you don't mind me asking
     
  3. Ray

    Ray Friend

    Friend
    Joined:
    Oct 27, 2015
    Likes Received:
    899
    Trophy Points:
    93
    Location:
    Louisiana
    WE396a, sitting on socket saver
     
    kirayamato likes this.
  4. kirayamato

    kirayamato Friend

    Friend
    Joined:
    Oct 18, 2015
    Likes Received:
    36
    Trophy Points:
    28
    @Ray oh okay i ordered that one already cool btw what are you using for the one above the power unit am currently on stock and trying to get a new one any recommendations?
     
  5. Ray

    Ray Friend

    Friend
    Joined:
    Oct 27, 2015
    Likes Received:
    899
    Trophy Points:
    93
    Location:
    Louisiana
    Amperex 5ar4
     
    jexby and cskippy like this.
  6. Melvillian

    Melvillian Friend

    Friend
    Joined:
    Jul 3, 2017
    Likes Received:
    559
    Trophy Points:
    93
    Location:
    Los Angeles
    You can get NOS Mullard GZ34 (5AR4) for probably cheaper than the amperex. Mullards are also excellent and they made tubes for pretty much everyone so you’ll find a lot of rebranded mullards out there.

    Changing the rectifier tube from the stock tube didn’t change the tonality, but it definitely lifts a veil. The amp just sounded supercharged. It’s like in the Fast and Furious movies where they press the NOS button
     
    kirayamato, JK47, bengo and 2 others like this.
  7. brencho

    brencho Good Friend (Moderator)

    Staff Member Friend
    Joined:
    Dec 18, 2015
    Likes Received:
    3,932
    Trophy Points:
    113
    Location:
    LA
    hahaha finally someone puts it in terms I can understand
     
    bazelio, bengo and Melvillian like this.
  8. kirayamato

    kirayamato Friend

    Friend
    Joined:
    Oct 18, 2015
    Likes Received:
    36
    Trophy Points:
    28
    thanks alot got the NOS !
    am actually changing them all the tubes as people have mentioned that am missing some gains as marv said that it should have more gian so probably thats the issue already changed the 2a3's so changing both the other tubes i got because they were the stocks one given
    if still theres gains missing then I don't know because even with the sennheiser hd 800 i need to turn the dial to 3-4 oclock to get decent volume
     
  9. cskippy

    cskippy Friend

    Friend
    Joined:
    Oct 14, 2015
    Likes Received:
    1,471
    Trophy Points:
    113
    Location:
    Tempe, Arizona
    There is something seriously wrong with your setup. Do you have another amp you can run into that works okay?
     
    Melvillian likes this.
  10. kirayamato

    kirayamato Friend

    Friend
    Joined:
    Oct 18, 2015
    Likes Received:
    36
    Trophy Points:
    28
    hm have the jotunheim that works fine will check after if the problem persists after I get the tubes and my friend actually has a gungnir i'll check with that aswell if the tubes don't fix it
     
    cskippy likes this.
  11. Melvillian

    Melvillian Friend

    Friend
    Joined:
    Jul 3, 2017
    Likes Received:
    559
    Trophy Points:
    93
    Location:
    Los Angeles
    Touch the output transformers (pair behind the power tubes) and see if they’re hot. Just to make sure they don’t get damaged in case something got loose inside during shipment.

    Also, did you try using the RCA inputs on the aficionado.
     
  12. Ray

    Ray Friend

    Friend
    Joined:
    Oct 27, 2015
    Likes Received:
    899
    Trophy Points:
    93
    Location:
    Louisiana
    Volume never went past 9 o’clock on my AF. Definitely something up with @kirayamato’s
    amp
     
    kirayamato likes this.
  13. Boops

    Boops Friend

    Friend
    Joined:
    Nov 8, 2015
    Likes Received:
    889
    Trophy Points:
    93
    Location:
    New York
    My volume is typically:
    9 o’clock for Utopias
    10 o’clock for 650s

    Add :30 if listening loud.
     
    kirayamato likes this.
  14. cskippy

    cskippy Friend

    Friend
    Joined:
    Oct 14, 2015
    Likes Received:
    1,471
    Trophy Points:
    113
    Location:
    Tempe, Arizona
    Couple of questions:

    Will any 5AR4 rectifier tube work with the PSU? I like the power of the stock tube. I've tried a Amperex Orange Globe and it takes the edge off smoothing things and allowing you to hear the microdetails better. I'm interested in trying one of the solid state 5AR4 tubes. Any recommendations?

    @Marvey What is the output impedance of Aficionado? Is it 3-4Ohms?

    Thanks!
     
  15. Daveheart

    Daveheart Friend

    Friend
    Joined:
    Jan 10, 2017
    Likes Received:
    548
    Trophy Points:
    93
    Location:
    Dallas, TX
    I can't answer the impedance question, but any 5AR4/GZ34 should work in the PS.
     
  16. jexby

    jexby Raised by Carthusian Monks - Friend

    Friend
    Joined:
    Sep 28, 2015
    Likes Received:
    2,046
    Trophy Points:
    113
    Location:
    CO
    except that (many?) old Mullard NOS 5AR4/GZ34 have a fatter plastic base which does not fit through the pre-cut hole in the metal casing.

    socket extender tho and the Mullards work and sound great.
     
  17. cskippy

    cskippy Friend

    Friend
    Joined:
    Oct 14, 2015
    Likes Received:
    1,471
    Trophy Points:
    113
    Location:
    Tempe, Arizona
  18. Daveheart

    Daveheart Friend

    Friend
    Joined:
    Jan 10, 2017
    Likes Received:
    548
    Trophy Points:
    93
    Location:
    Dallas, TX
    All I can say on those is that I've never cared for them (in a ST-70 and multiple guitar amps). I've haven't tried them in any of my current gear that makes use of a 5AR4.
     
    cskippy likes this.

Share This Page