Schiit Urd Impressions

Discussion in 'Digital: DACs, USB converters, decrapifiers' started by purr1n, Jul 12, 2023.

  1. HeyWaj10

    HeyWaj10 Facebook Friend

    Contributor
    Joined:
    Jan 10, 2022
    Likes Received:
    248
    Trophy Points:
    43
    Location:
    Cary, NC
    Curious for those of you who have used an iPad or iPhone into the Urd's USB inputs - will an OTG cable work for the connection, or is the Apple Lightning to USB3 Camera Adapter still required for the signal to pass through?
     
  2. sheldaze

    sheldaze Friend

    Pyrate
    Joined:
    May 28, 2016
    Likes Received:
    977
    Trophy Points:
    93
    Location:
    Land of Merriment
    Yes, it works for me directly from the iPad, which I can test easily because mine has the USB-C cable. I don't have the cables to test my old iPhone.
     
    • Agreed, ditto, +1 Agreed, ditto, +1 x 1
    • List
  3. Bowmoreman

    Bowmoreman Facebook Friend

    Contributor
    Joined:
    Jun 28, 2023
    Likes Received:
    204
    Trophy Points:
    43
    Location:
    Temple, NH
    Wow (was lurking around)… I thought I was likely the only one out there still using a Cal Delta as a transport! I’ve had it so long (and so many moves) that I lost the remote (sniff); but works great in my desktop rig where it’s at fingers reach…
     
  4. Kernel Kurtz

    Kernel Kurtz Friend

    Pyrate Contributor
    Joined:
    May 19, 2018
    Likes Received:
    1,696
    Trophy Points:
    93
    Location:
    Winnipeg, Canada
    So I've been super happy with my Urd, till today. Now I am sad. Powered up the system with the disc that was in it when I last listened, and it will neither play nor eject the disc. It is a burned Redbook format CD I have listened to on the Urd many times before with no issues. I've left it unplugged, and left it powered on. I can hear the laser mechanism moving when I try to play or eject, but no joy. Will send an email to Schiit on Monday if I can't get it to eject by then, but just wondering if anyone has any ideas? TIA
     
  5. JK47

    JK47 Friend

    Pyrate
    Joined:
    Oct 31, 2022
    Likes Received:
    2,102
    Trophy Points:
    93
    Location:
    Surf City USA
    Anti-pirate time bomb...
     
  6. Kernel Kurtz

    Kernel Kurtz Friend

    Pyrate Contributor
    Joined:
    May 19, 2018
    Likes Received:
    1,696
    Trophy Points:
    93
    Location:
    Winnipeg, Canada
    Except copy of a disc I already own :-/
     
    • Miss Information Miss Information x 1
    • List
  7. rfernand

    rfernand Almost "Made"

    BWC Contributor
    Joined:
    Oct 10, 2022
    Likes Received:
    731
    Trophy Points:
    93
    Location:
    Kirkland, WA
    Oh no! I’d contact Schiit directly if I were you.
     
  8. Kernel Kurtz

    Kernel Kurtz Friend

    Pyrate Contributor
    Joined:
    May 19, 2018
    Likes Received:
    1,696
    Trophy Points:
    93
    Location:
    Winnipeg, Canada
    Got my Urd back today. Looks like they replaced the drive according to the repair sheet. Was a pretty painless warranty process in any case, so thanks to Schiit Audio for that. Pi2AES filled in nicely while it was gone, but good to be able to play CDs again.
     
  9. Metro

    Metro Friend

    Pyrate
    Joined:
    Dec 27, 2016
    Likes Received:
    1,600
    Trophy Points:
    93
    Location:
    San Francisco
    There must've been a bad batch of drives from the supplier. Today someone posted on the Schiit thread at Head-Fi that their Urd tray mechanism was failing. Then several others reported that they'd had a similar problem and that Schiit replaced the drive.
     
  10. Kernel Kurtz

    Kernel Kurtz Friend

    Pyrate Contributor
    Joined:
    May 19, 2018
    Likes Received:
    1,696
    Trophy Points:
    93
    Location:
    Winnipeg, Canada
    Thanks for the info, that is good to know. If it is more than just a random occurrence hopefully the root cause has been addressed in the fix and it will no longer be a potential problem going forward.
     
  11. Polemarkos

    Polemarkos Facebook Friend

    Contributor
    Joined:
    Oct 16, 2018
    Likes Received:
    173
    Trophy Points:
    33
    Location:
    Holland, MI
    I've been having an issue with the Urd since shortly after I received it and am curious if anyone else has seen the same. I've never had any issues with an AES connection between Urd and Yggdrasil LIM. USB connection b/t Urd and Yggdrasil will randomly become very distorted while using Roon; song slows way down, 'screeching' sounds and other significant distortion etc. Turning the Urd off and on again will resolve the issue until it inevitably (days, weeks) happens again. I've swapped all the short (less than 6 feet) and cheap USB cables twice between my PC/Urd/Yggdrasil twice and the issue persists. It might still be a cable issue but wanted to solicit other opinions before dropping $$$ on some of the better cables recommended in the USB cable thread.
     
  12. Metro

    Metro Friend

    Pyrate
    Joined:
    Dec 27, 2016
    Likes Received:
    1,600
    Trophy Points:
    93
    Location:
    San Francisco
    Does simply stopping and restarting the current track on Roon resolve it? I doubt that a USB cable would cause such a issue. I would first contact Schiit and describe your problem.

    Occasionally (no more than about once a month), I start something on Roon and it begins playing at a slow speed (½ or ¼). I restart the track and it plays fine. It only happens while beginning to play — it doesn't spontaneously switch to this mode in the middle of playing. Is this similar to what you experience?

    I'm running NUC Roon Core > WiFi > RPi/Pi2AES > AES > DAC (no USB in the path). I figure that software or firmware might have gotten into a bad state that gets reset when playback is restarted.
     
  13. Polemarkos

    Polemarkos Facebook Friend

    Contributor
    Joined:
    Oct 16, 2018
    Likes Received:
    173
    Trophy Points:
    33
    Location:
    Holland, MI
    Restarting the track in Roon and/or restarting Roon doesn't fix the issue. The only way to fix is turn the Urd off/on. I've never had the issue you described while using the AES output.

    Just yesterday I set up an Allo USBSignature as a Roon endpoint connected to an LPS, removing my PC from the playback chain. If the issue happens again I'll get in-touch with Schiit. I have some concerns about not being able to reproduce the issue on-demand, and the fact that Roon is my only use-case outside occasional CD-playback. I've spent maybe 10 hours listening via CD and haven't experienced the issue in that context.
     
  14. keemniloc

    keemniloc New

    Joined:
    Oct 2, 2015
    Likes Received:
    4
    Trophy Points:
    3
    I experience the same symptoms with roon to pi2aes ropieee to urd to Yggdrasil A2 unison. No issues with AES. It seems to happen only on sample rate changes, and turning the urd off and on again addresses the issue. (Not much an annoyance to me so I haven’t bugged schiit)
     
  15. rfernand

    rfernand Almost "Made"

    BWC Contributor
    Joined:
    Oct 10, 2022
    Likes Received:
    731
    Trophy Points:
    93
    Location:
    Kirkland, WA
    No repro over here - which sample rate changes make it barf? I’ve tried 44.1/16 and 192/24 back and forth.

    @schiit fyi
     
    Last edited: Apr 5, 2024
  16. Polemarkos

    Polemarkos Facebook Friend

    Contributor
    Joined:
    Oct 16, 2018
    Likes Received:
    173
    Trophy Points:
    33
    Location:
    Holland, MI
    Glad to hear I'm not the only one that's experienced this. I've had the distortion start even when Roon is conifgured to upsample to the native resolution of the DAC, and the issue occurs mid-track so after any 'clicks' would have happened to register a change in sample rate were I not upsampling.
     
  17. Polemarkos

    Polemarkos Facebook Friend

    Contributor
    Joined:
    Oct 16, 2018
    Likes Received:
    173
    Trophy Points:
    33
    Location:
    Holland, MI
    The issue has cropped up quite a number of times since installing the USBridge. Restarting the track has ended the distortion in two cases, but the distortion quickly resumed. In a third case restarting the track did not resolve the distortion and I had to power-cycle the Urd. The only thing that mitigates this definitely being an issue related to Roon in/compatibility is that I've never had the issue present itself when using the AES connection. Then again, since this is exclusively a Roon-related issue, and no support for Roon is expressed or implied, I guess I'm stuck. Nothing on the Roon forums, either.
     
  18. MrChinaCat

    MrChinaCat New

    Contributor
    Joined:
    Jul 1, 2018
    Likes Received:
    95
    Trophy Points:
    13
    Location:
    Rochester
    Something to try — Roon has a feature that adds a brief re-sync delay when changing rates to a device. I have used it for a DAC that tended to hesitate at changes. Maybe adjusting that delay will help.
     
  19. Polemarkos

    Polemarkos Facebook Friend

    Contributor
    Joined:
    Oct 16, 2018
    Likes Received:
    173
    Trophy Points:
    33
    Location:
    Holland, MI
    I had resync delay configured already, unfortunately, and I believe this feature only applies to the beginning of a track while the issue I've had occurs randomly in the middle or near the end as well.
     
  20. crenca

    crenca Friend

    Pyrate
    Joined:
    May 26, 2017
    Likes Received:
    3,990
    Trophy Points:
    113
    Location:
    Southern New Mexico
    Maybe reinstall Roon - perhaps first on another computer to see if you can replicate it from there?
     

Share This Page