SWTP 207/A help

Discussion in 'Power Amps' started by spwath, Apr 13, 2017.

  1. spwath

    spwath Collegiate hijinks master

    Friend BWC
    Joined:
    Dec 13, 2015
    Likes Received:
    6,753
    Trophy Points:
    113
    Location:
    Hartford, CT
    So I just got this amp from my friend, who said volume knob didn't work, just played at max volume. I set it up, nothing but a rather large humming (coming out of speakers), and a burning smell. Any thoughts?
    I thinking the no sound is from the volume knob being down, but I was a bit concerned by the humming, and a lot concerned by the smell.
    Also, whats with the inputs (this is a mono amp) labled AC and DC?
    Any ideas on which I'm supposed to plug into?
    WP_20170413_22_07_01_Pro.jpg WP_20170413_22_07_15_Pro.jpg WP_20170413_22_07_35_Pro.jpg
     
  2. Dino

    Dino Friend

    Friend
    Joined:
    Jun 21, 2016
    Likes Received:
    3,525
    Trophy Points:
    113
    I googled SWTP 207/A. Looks like it was also known as "Tiger .01". It was sold as a kit or assembled.
    SWTPC Tiger .01 207A Schematic and Parts List

    One guy says to use the DC input as the Line In. I didn't see any mention of the AC input.

    I read 4 different mentions of them "blowing up" and 3 of them catching on fire. (I didn't spend a lot of time researching this but it seems kind of scary to me.)
     
  3. spwath

    spwath Collegiate hijinks master

    Friend BWC
    Joined:
    Dec 13, 2015
    Likes Received:
    6,753
    Trophy Points:
    113
    Location:
    Hartford, CT
    hmm... Don't really want that to happen... I might just harvest some of the parts from it for other stuff.
     

Share This Page